Cloudflare outage

Incident Report for jottocraft

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 13:40 PDT

Identified

All jottocraft online services are currently unavailable due to an ongoing Cloudflare outage. Please check cloudflarestatus.com for updates from Cloudflare.
Posted Jun 12, 2025 - 11:15 PDT
This incident affected: Caltrain Live realtime data, jottocraft ID, Power+, and jottocraft.com and static project pages.